Tóm tắt nhanh
- CVE-2026-34236 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.8) ảnh hưởng auth0/auth0-php, auth0-php (auth0).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.22%, cao hơn 13.2% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 8.19.0 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| auth0/auth0-php Packagist | ≥ 8.0.0, < 8.19.0
| 8.19.0
|
| auth0-php | ≥ 8.0.0, < 8.19.0
| 8.19.0
|
Mô tả
Impact
In applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies.
Am I Affected?
Consumers are affected if their application meets the following preconditions:
- Their application is using the Auth0-PHP SDK, versions between 8.0.0 and 8.18.0
- Their application is using the Auth0-PHP SDK, or the following SDKs that rely on the Auth0-PHP SDK:
- Auth0/symfony,
- Auth0/laravel0-auth0, or
- Auth0/wordpress
Resolution
Upgrade Auth0/Auth0-PHP to version 8.19.0 or greater.
Mô tả của NVD
Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. From version 8.0.0 to before version 8.19.0, in applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. This issue has been patched in version 8.19.0.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí