| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| TinyMCE | ≥ 7.9.3, < 7.9.4≥ 8.5.1, < 8.9.3 | 7.9.48.9.3 |
| tinymce/tinymce | ≥ 7.9.3, < 7.9.4≥ 8.5.1, < 8.9.3 | 7.9.48.9.3 |
| tinymce | ≥ 7.9.3, < 7.9.4≥ 8.5.1, < 8.9.3 | 7.9.48.9.3 |
Stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via elements crafted through the data-mce-object attribute, which are created and executed before sanitization. Impacts users of TinyMCE with the media plugin enabled.
This vulnerability has been patched in TinyMCE 8.9.3 and TinyMCE 7.9.4 by ensuring that, when using the media plugin, any content created through the data-mce-object attribute is properly sanitized first.
No official workaround available.
To avoid this vulnerability:
Upgrade to TinyMCE 8.9.3 or higher. Upgrade to TinyMCE 7.9.4 or higher.
Tiny thanks Fariskhi Vidyan and David Vieira Kurz (HiSolutions AG) for their help identifying this vulnerability.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí