| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| TinyMCE | ≥ 6.0.0, < 7.9.3≥ 8.0.0, < 8.5.1≤ 5.10.9 | 7.9.38.5.1 |
| tinymce/tinymce | ≥ 6.0.0, < 7.9.3≥ 8.0.0, < 8.5.1≤ 5.10.9 | 7.9.38.5.1 |
| tinymce | ≥ 6.0.0, < 7.9.3≥ 8.0.0, < 8.5.1< 5.11.1 | 7.9.38.5.15.11.1 |
| tinymce | ≥ 6.0.0, < 7.9.3≥ 8.0.0, < 8.5.1≤ 5.10.9 | 7.9.38.5.1 |
Stored XSS vulnerability via forged mce:protected comments. Allows attackers to bypass sanitization and inject scripts that execute when content is restored. Impacts users who utilize the protect option.
Patched by validating decoded mce:protected content against configured protect regex rules before restoring. Users should upgrade to the latest patched version.
No official workaround available.
To avoid this vulnerability:
Upgrade to TinyMCE 8.5.1 or higher. Upgrade to TinyMCE 7.9.3 or higher. Upgrade to TinyMCE 5.11.1 LTS or higher for TinyMCE 5.x (only available as part of commercial long-term support contract).
Tiny thanks Ivan Babenko for their help identifying this vulnerability.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí