| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| TinyMCE | ≥ 6.8.0, < 7.1.0 | 7.1.0 |
| tinymce/tinymce | ≥ 6.8.0, < 7.1.0 | 7.1.0 |
| tinymce | ≥ 6.8.0, < 7.1.0 | 7.1.0 |
| tinymce | ≥ 6.8.0, < 7.1.0 | 7.1.0 |
TinyMCE 6.8.x contains an XSS vulnerability caused by improper SVG namespace scope handling in the sanitizer. A crafted payload using nested <svg> elements can bypass attribute sanitization and execute arbitrary JavaScript.
This issue affects TinyMCE 6.8.x-7.0.x. The vulnerability is fixed in TinyMCE 7.1.0 and later.
No official workaround available.
Tiny thanks maple3142 (https://maple3142.net) of DEVCORE for their help identifying this vulnerability.
Fix introduced in TinyMCE 7.1.0 though a rewrite of code causing the vulnerability.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí