In short
- CVE-2014-1832 is a LOW (CVSS 2.1) vulnerability affecting passenger, passenger (phusion).
- Chance of exploitation in the next 30 days (EPSS): 0.37%, higher than 31.0% of all vulnerabilities.
- Fix: update to 4.0.38 or later.
| Package | Affected versions | Patched versions |
|---|
| passenger RubyGems | ≥ 4.0.37, < 4.0.38
| 4.0.38
|
| passenger | ≤ 4.0.36
| No fix yet |
Description
Phusion Passenger 4.0.37 allows local users to write to certain files and directories via a symlink attack on (1) control_process.pid or a (2) generation-* file. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-1831.
NVD description
Phusion Passenger 4.0.37 allows local users to write to certain files and directories via a symlink attack on (1) control_process.pid or a (2) generation-* file. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-1831.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free