In short
- CVE-2018-12029 is a HIGH (CVSS 7.0) vulnerability affecting passenger, passenger (phusion).
- Chance of exploitation in the next 30 days (EPSS): 0.27%, higher than 19.8% of all vulnerabilities.
- Fix: update to 5.3.2 or later.
| Package | Affected versions | Patched versions |
|---|
| passenger RubyGems | ≥ 3.0.0, < 5.3.2
| 5.3.2
|
| passenger | ≥ 3.0.0, < 5.3.2
| 5.3.2
|
Description
A race condition in the nginx module in Phusion Passenger 3.x through 5.x before 5.3.2 allows local escalation of privileges when a non-standard passenger_instance_registry_dir with insufficiently strict permissions is configured. Replacing a file with a symlink after the file was created, but before it was chowned, leads to the target of the link being chowned via the path. Targeting sensitive files such as root's crontab file allows privilege escalation.
NVD description
A race condition in the nginx module in Phusion Passenger 3.x through 5.x before 5.3.2 allows local escalation of privileges when a non-standard passenger_instance_registry_dir with insufficiently strict permissions is configured. Replacing a file with a symlink after the file was created, but before it was chowned, leads to the target of the link being chowned via the path. Targeting sensitive files such as root's crontab file allows privilege escalation.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free