In short
- CVE-2018-12028 is a HIGH (CVSS 7.8) vulnerability affecting passenger, passenger (phusion).
- Chance of exploitation in the next 30 days (EPSS): 0.89%, higher than 59.3% of all vulnerabilities.
- Fix: update to 5.3.2 or later.
| Package | Affected versions | Patched versions |
|---|
| passenger RubyGems | ≥ 5.3.0, < 5.3.2
| 5.3.2
|
| passenger | ≥ 5.3.0, < 5.3.2
| 5.3.2
|
Description
An Incorrect Access Control vulnerability in SpawningKit in Phusion Passenger 5.3.x before 5.3.2 allows a Passenger-managed malicious application, upon spawning a child process, to report an arbitrary different PID back to Passenger's process manager. If the malicious application then generates an error, it would cause Passenger's process manager to kill said reported arbitrary PID.
NVD description
An Incorrect Access Control vulnerability in SpawningKit in Phusion Passenger 5.3.x before 5.3.2 allows a Passenger-managed malicious application, upon spawning a child process, to report an arbitrary different PID back to Passenger's process manager. If the malicious application then generates an error, it would cause Passenger's process manager to kill said reported arbitrary PID.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free