In short
- CVE-2018-12027 is a HIGH (CVSS 8.8) vulnerability affecting passenger, passenger (phusion).
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 64.9% of all vulnerabilities.
- Fix: update to 5.3.2 or later.
| Package | Affected versions | Patched versions |
|---|
| passenger RubyGems | ≥ 5.3.0, < 5.3.2
| 5.3.2
|
| passenger | ≥ 5.3.0, < 5.3.2
| 5.3.2
|
Description
An Insecure Permissions vulnerability in SpawningKit in Phusion Passenger 5.3.x before 5.3.2 causes information disclosure in the following situation: given a Passenger-spawned application process that reports that it listens on a certain Unix domain socket, if any of the parent directories of said socket are writable by a normal user that is not the application's user, then that non-application user can swap that directory with something else, resulting in traffic being redirected to a non-application user's process through an alternative Unix domain socket.
NVD description
An Insecure Permissions vulnerability in SpawningKit in Phusion Passenger 5.3.x before 5.3.2 causes information disclosure in the following situation: given a Passenger-spawned application process that reports that it listens on a certain Unix domain socket, if any of the parent directories of said socket are writable by a normal user that is not the application's user, then that non-application user can swap that directory with something else, resulting in traffic being redirected to a non-application user's process through an alternative Unix domain socket.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free