In short
- CVE-2018-12615 is a MEDIUM (CVSS 5.3) vulnerability affecting passenger, passenger (phusion).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 67.7% of all vulnerabilities.
- Fix: update to 5.3.2 or later.
| Package | Affected versions | Patched versions |
|---|
| passenger RubyGems | < 5.3.2
| 5.3.2
|
| passenger | < 5.3.2
| 5.3.2
|
Description
An issue was discovered in switchGroup() in agent/ExecHelper/ExecHelperMain.cpp in Phusion Passenger before 5.3.2. The set of groups (gidset) is not set correctly, leaving it up to randomness (i.e., uninitialized memory) which supplementary groups are actually being set while lowering privileges.
NVD description
An issue was discovered in switchGroup() in agent/ExecHelper/ExecHelperMain.cpp in Phusion Passenger before 5.3.2. The set of groups (gidset) is not set correctly, leaving it up to randomness (i.e., uninitialized memory) which supplementary groups are actually being set while lowering privileges.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free