In short
- CVE-2025-26803 is a HIGH (CVSS 7.5) vulnerability affecting passenger, passenger (phusion).
- Chance of exploitation in the next 30 days (EPSS): 0.62%, higher than 49.9% of all vulnerabilities.
- Fix: update to 6.0.26 or later.
| Package | Affected versions | Patched versions |
|---|
| passenger RubyGems | ≥ 6.0.21, < 6.0.26
| 6.0.26
|
| passenger | ≥ 6.0.21, < 6.0.26
| 6.0.26
|
Description
The http parser in Phusion Passenger 6.0.21 through 6.0.25 before 6.0.26 allows a denial of service during parsing of a request with an invalid HTTP method.
NVD description
The http parser in Phusion Passenger 6.0.21 through 6.0.25 before 6.0.26 allows a denial of service during parsing of a request with an invalid HTTP method.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free