In short
- CVE-2018-12026 is a CRITICAL (CVSS 9.8) vulnerability affecting passenger, passenger (phusion).
- Chance of exploitation in the next 30 days (EPSS): 1.9%, higher than 79.9% of all vulnerabilities.
- Fix: update to 5.3.2 or later.
| Package | Affected versions | Patched versions |
|---|
| passenger RubyGems | ≥ 5.3.0, < 5.3.2
| 5.3.2
|
| passenger | ≥ 5.3.0, < 5.3.2
| 5.3.2
|
Description
During the spawning of a malicious Passenger-managed application, SpawningKit in Phusion Passenger 5.3.x before 5.3.2 allows such applications to replace key files or directories in the spawning communication directory with symlinks. This then could result in arbitrary reads and writes, which in turn can result in information disclosure and privilege escalation.
NVD description
During the spawning of a malicious Passenger-managed application, SpawningKit in Phusion Passenger 5.3.x before 5.3.2 allows such applications to replace key files or directories in the spawning communication directory with symlinks. This then could result in arbitrary reads and writes, which in turn can result in information disclosure and privilege escalation.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free