In short
- CVE-2020-13822 is a HIGH (CVSS 7.7) vulnerability affecting elliptic (indutny), elliptic.
- Chance of exploitation in the next 30 days (EPSS): 2.7%, higher than 86.0% of all vulnerabilities.
- Fix: update to 6.5.3 or later.
| Package | Affected versions | Patched versions |
|---|
| elliptic | = 6.5.2
| No fix yet |
| elliptic npm | < 6.5.3
| 6.5.3
|
Description
The Elliptic package before version 6.5.3 for Node.js allows ECDSA signature malleability via variations in encoding, leading '\0' bytes, or integer overflows. This could conceivably have a security-relevant impact if an application relied on a single canonical signature.
NVD description
The Elliptic package 6.5.2 for Node.js allows ECDSA signature malleability via variations in encoding, leading '\0' bytes, or integer overflows. This could conceivably have a security-relevant impact if an application relied on a single canonical signature.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free