In short
- CVE-2024-42459 is a MEDIUM (CVSS 5.3) vulnerability affecting elliptic (indutny), elliptic.
- Chance of exploitation in the next 30 days (EPSS): 0.30%, higher than 23.0% of all vulnerabilities.
- Fix: update to 6.5.7 or later.
| Package | Affected versions | Patched versions |
|---|
| elliptic | = 6.5.6
| No fix yet |
| elliptic npm | ≥ 4.0.0, < 6.5.7
| 6.5.7
|
Description
In the Elliptic package 6.5.6 for Node.js, EDDSA signature malleability occurs because there is a missing signature length check, and thus zero-valued bytes can be removed or appended.
NVD description
In the Elliptic package 6.5.6 for Node.js, EDDSA signature malleability occurs because there is a missing signature length check, and thus zero-valued bytes can be removed or appended.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free