In short
- CVE-2020-28498 is a MEDIUM (CVSS 6.8) vulnerability affecting elliptic (indutny), elliptic.
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 69.5% of all vulnerabilities.
- Fix: update to 6.5.4 or later.
| Package | Affected versions | Patched versions |
|---|
| elliptic | < 6.5.4
| 6.5.4
|
| elliptic npm | < 6.5.4
| 6.5.4
|
Description
The npm package elliptic before version 6.5.4 are vulnerable to Cryptographic Issues via the secp256k1 implementation in elliptic/ec/key.js. There is no check to confirm that the public key point passed into the derive function actually exists on the secp256k1 curve. This results in the potential for the private key used in this implementation to be revealed after a number of ECDH operations are performed.
NVD description
The package elliptic before 6.5.4 are vulnerable to Cryptographic Issues via the secp256k1 implementation in elliptic/ec/key.js. There is no check to confirm that the public key point passed into the derive function actually exists on the secp256k1 curve. This results in the potential for the private key used in this implementation to be revealed after a number of ECDH operations are performed.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free