In short
- CVE-2024-42460 is a MEDIUM (CVSS 5.3) vulnerability affecting elliptic (indutny), elliptic.
- Chance of exploitation in the next 30 days (EPSS): 0.46%, higher than 39.9% of all vulnerabilities.
- Fix: update to 6.5.7 or later.
| Package | Affected versions | Patched versions |
|---|
| elliptic | = 6.5.6
| No fix yet |
| elliptic npm | ≥ 2.0.0, < 6.5.7
| 6.5.7
|
Description
In the Elliptic package 6.5.6 for Node.js, ECDSA signature malleability occurs because there is a missing check for whether the leading bit of r and s is zero.
NVD description
In the Elliptic package 6.5.6 for Node.js, ECDSA signature malleability occurs because there is a missing check for whether the leading bit of r and s is zero.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free