In short
- CVE-2024-48948 is a MEDIUM (CVSS 4.8) vulnerability affecting elliptic (indutny), elliptic.
- Chance of exploitation in the next 30 days (EPSS): 0.55%, higher than 46.3% of all vulnerabilities.
- Fix: update to 6.6.0 or later.
| Package | Affected versions | Patched versions |
|---|
| elliptic | = 6.5.7
| No fix yet |
| elliptic npm | < 6.6.0
| 6.6.0
|
Description
The Elliptic prior to 6.6.0 for Node.js, in its for ECDSA implementation, does not correctly verify valid signatures if the hash contains at least four leading 0 bytes and when the order of the elliptic curve's base point is smaller than the hash, because of an _truncateToN anomaly. This leads to valid signatures being rejected. Legitimate transactions or communications may be incorrectly flagged as invalid.
NVD description
The Elliptic package 6.5.7 for Node.js, in its for ECDSA implementation, does not correctly verify valid signatures if the hash contains at least four leading 0 bytes and when the order of the elliptic curve's base point is smaller than the hash, because of an _truncateToN anomaly. This leads to valid signatures being rejected. Legitimate transactions or communications may be incorrectly flagged as invalid.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free