Tóm tắt nhanh
- CVE-2024-38356 là lỗ hổng mức TRUNG BÌNH (CVSS 6.1) ảnh hưởng TinyMCE, tinymce/tinymce, django-tinymce.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.53%, cao hơn 44.8% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 6.8.4, 7.2.0, 5.11.0, 4.1.0 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| TinyMCE NuGet | ≥ 6.0.0, < 6.8.4≥ 7.0.0, < 7.2.0< 5.11.0
| 6.8.47.2.05.11.0
|
| tinymce/tinymce Packagist | ≥ 6.0.0, < 6.8.4≥ 7.0.0, < 7.2.0< 5.11.0
| 6.8.47.2.05.11.0
|
| django-tinymce PyPI | < 4.1.0
| 4.1.0
|
| tinymce npm | ≥ 6.0.0, < 6.8.4≥ 7.0.0, < 7.2.0< 5.11.0
| 6.8.47.2.05.11.0
|
Mô tả
Impact
A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content extraction code. When using the noneditable_regexp option, specially crafted HTML attributes containing malicious code were able to be executed when content was extracted from the editor.
Patches
This vulnerability has been patched in TinyMCE 7.2.0, TinyMCE 6.8.4 and TinyMCE 5.11.0 LTS by ensuring that, when using the noneditable_regexp option, any content within an attribute is properly verified to match the configured regular expression before being added.
Fix
To avoid this vulnerability:
- Upgrade to TinyMCE 7.2.0 or higher.
- Upgrade to TinyMCE 6.8.4 or higher for TinyMCE 6.x.
- Upgrade to TinyMCE 5.11.0 LTS or higher for TinyMCE 5.x (only available as part of commercial long-term support contract).
References
For more information
If you have any questions or comments about this advisory:
Mô tả của NVD
TinyMCE is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content extraction code. When using the `noneditable_regexp` option, specially crafted HTML attributes containing malicious code were able to be executed when content was extracted from the editor. This vulnerability has been patched in TinyMCE 7.2.0, TinyMCE 6.8.4 and TinyMCE 5.11.0 LTS by ensuring that, when using the `noneditable_regexp` option, any content within an attribute is properly verified to match the configured regular expression before being added. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí